Hubspot API Not Working

Scubydew
Member

Good Afternoon,

Our Hubspot API stopped functioning from Salesforce to Hubspot.

Do I need to create a new API Key?

Daniel

0 Upvotes
6 Replies 6
bradmin
Key Advisor

Hi, @dferrara. If you’re talking about HubSpot’s native connector for Salesforce, that won’t use any API key you might use for custom development. That uses OAuth to validate whichever Salesforce user’s credentials you’ve defined in HubSpot. The Salesforce connector settings page in-app in HubSpot should contain information about the nature of the suspension.


Brad Mampe, Salesforce Analyst, Fidelity
I'm probably wrong. I may not be right about that.
Scubydew
Member

I am talking about the Hubspot API

0 Upvotes
Scubydew
Member

What suspension? I have no idea of any suspension?

0 Upvotes
Scubydew
Member

This is my code and the API key is on line 4 if there problem with the key, how do generate a new key.

public class HubSpotHandler
{
// lead owner would be changed to the user who clicked the button -04/27/2016
protected String HAPIKey=‘REDACTED’;
protected String API_PATH;
protected String API_VERSION;
protected String PATH_DIV = ‘/’;
protected String PROD_DOMAIN = ‘https://api.hubapi.com’;

public HubSpotHandler(ApexPages.StandardController sc)
{
}
@future (callout=true)
public static void createCompanies(String accId)
{
    String HAPIKey='**REDACTED**';
    Account Acc=[Select name, description, BillingCity,BillingCountry,BillingPostalCode,BillingState,BillingStreet,Entity_Title__c,
    DBA__c, Deal_stage__c, Hunt_stage__c, Vantage_Score__c, Action_Required__c, Fax_In_App__c, email_address__c, Email_Address_2__c,App_Out_Date__c, App_In_Date__c,
0 Upvotes
Derek_Gervais
HubSpot Employee

Hi @dferrara,

Can you give me some more information on the error you’re seeing? Any full error logs would be great. Additionally, I would recommend against including your API key on any post/topic here, since this is a public forum. I’ve removed it from your last post, but since it was visible here for ~18 hours you might consider generating a new key.

0 Upvotes
Scubydew
Member

Hi Derek,

I think it had something to do with DNS our server was down and probably
had not updated. Everything is good now Derek.

Thanks :slight_smile:

Dan Ferrara
IT Manager
949-238-6623 | dferrara@capitalalliance.com | www.capitalalliance.com

https://www.facebook.com/capitalnow?utm_source=WiseStamp&utm_medium=email&utm_term=&utm_content=&utm...

https://twitter.com/capalliance?utm_source=WiseStamp&utm_medium=email&utm_term=&utm_content=&utm_cam...

https://www.linkedin.com/company/capital-alliance-corporation?utm_source=WiseStamp&utm_medium=email&...

https://youtu.be/TzvKWoIQyMk?utm_source=WiseStamp&utm_medium=email&utm_term=&utm_content=&utm_campai...

This email and any files transmitted with it are confidential and are
intended solely for the use of the individual or entity to whom they are
addressed. This communication may represent the originator’s personal views
and opinions, which do not necessarily reflect those of Capital Alliance
Group. If you are not the original recipient or the person responsible for
delivering the email to the intended recipient, be advised that you have
received this email in error, and that any use, dissemination, forwarding,
printing, or copying of this email is strictly prohibited.