How to resolve OAuth "Insufficient scopes provided" error message?


I’m attempting to setup and install (OAuth) a new Hubspot application and I receiving the following error upon initiation the OAuth authorization process: Insufficient scopes provided.

I have an existing (and working) application setup under my developer account (App ID 33094). This application is working and used regularly.I’m now setting up a second application (App ID 52988) within the same developer account. This new app is configured exactly the same as the working app, and yet authorization fails with the error mentioned above. The app grants access to Contacts, Content, Social, Workflows, and Forms. Also, NONE of the optional scopes are selected, which I take to mean, the authorization is NOT required to include any scopes.

Since the above setup failed, I think I have tried every possible combination of scopes/entities in the application configuration page, and regardless the combination, the result is the same (insufficient scopes error). I’ve also tried authorizing a second integration using the working application (33094) and this fails with the same error.

Below is a sample authorization URL: social automation timeline

Has anyone else encountered this and found a resolution. Similar posts in this forum don’t offer any definitive answer. Thanks in advance for any assistance.

1 Reply 1

The solution I implemented for this problem was to put all of the scopes I required in the access_token request, but leave all but contacts unchecked in the app UI section. It’s not a real clean solution, but it did the trick for me.