日本語コミュニティーへようこそ!コミュニティーを使い始めるには

をご覧ください

Help understand Form API Response

解決
常連投稿者

We're trying to understand why some form data sent through the API by one of our partners was not received in our Hubspot platform.

They received this response:
http code 204: no content

I believe 204 is the correct response but unsure if the 'no content' bit indicates an issue?

Thanks in advance

返信
0 いいね!
承認済みベストアンサー

受理された解決策
コミュニティーマネージャー

Hi @simon,

A 204 no content is the expected response for a successful submission; the 'no content' is a part of the response and does not indicate a problem. Can you give me a link to the form you're referring to in HubSpot? And if possible, a rough date/time of the failed submission?

4件の返信4
HubSpot製品開発チーム

Hello Simon,

Thanks for reaching out. Do you see a new form submission within HubSpot? Even if there is no data, there should be a new submission, even if it's empty.

In addition, we do have a product limit to how many form submissions a contact can make- please take a look here: https://developers.hubspot.com/docs/faq/contact-and-form-limits

All the best,

Flora

Highlighted
常連投稿者

Hi Flora, thanks for your help. We don't see anything at the date/time when the referrer sent the data originally, so there's no empty form submission.

The examples we're looking at are newly created contacts, so the product limits shouldn't apply here.

If they received a 204 response but the empty submission isn't appearing, is the fault with Hubspot API rather than our referrer? What can we do to determine this and/or resolve it from happening again?

返信
0 いいね!
コミュニティーマネージャー

Hi @simon,

A 204 no content is the expected response for a successful submission; the 'no content' is a part of the response and does not indicate a problem. Can you give me a link to the form you're referring to in HubSpot? And if possible, a rough date/time of the failed submission?

常連投稿者

Thanks for clarifying on "204" and "no content" Derek.

On further investigation it looks like the submissions that we thought were missing are actually in Hubspot, however at a later date than expected due to a manual step in the process being delayed.

Thanks again.

返信
0 いいね!