APIs & Integrations

devphoenix
Member

GET contact API giving wrong response when ListId not available

Hi team,

I have encountered an issue where the GET contacts API is giving wrong response message.

 

API: https://api.hubapi.com/contacts/v1/lists/1/contacts/all

 

Correct response when listId available but when listId is not present it still gives 200 response with empty contact.Ideally it should be 404 with response of `List Id not deleted` something like that.

Reference recording : https://app.claap.io/brevo-1/hub-spot-issue-c-3YfMIiN6mG-u7j7sFTEMef0

Can you please fix this issue in your API.
Thanks

0 Upvotes
4 Replies 4
devphoenix
Member

GET contact API giving wrong response when ListId not available

Any update???

0 Upvotes
MiaSrebrnjak
Community Manager
Community Manager

GET contact API giving wrong response when ListId not available

Hi @devphoenix

 

Thank you for reaching out to the Community! 

I've asked our technical team for advice and it seems that you are using a legacy endpoint (v1).

Could you try using a more recent endpoint (v3) and see if the problem persists? https://developers.hubspot.com/docs/api/crm/lists 

 

Thank you, 

Mia, Community team 

 


Wusstest du, dass es auch eine DACH-Community gibt?
Nimm an regionalen Unterhaltungen teil, indem du deine Spracheinstellungen änderst


Did you know that the Community is available in other languages?
Join regional conversations by
changing your language settings

0 Upvotes
devphoenix
Member

GET contact API giving wrong response when ListId not available

Hi @MiaSrebrnjak 

Thanks for the response, may you please share the latest API postman curl.

Also, please share the correct API which I can use to achieve the same goal to fetch all the contacts from a specific list.

Thanks

0 Upvotes
devphoenix
Member

GET contact API giving wrong response when ListId not available

any update?

0 Upvotes