Fields created by API are not updated

SOLVE
Highlighted
New Contributor

Hello

 

I have created this form: https://api.hubapi.com/forms/v2/forms/6c32dbf4-4649-4a3b-b262-527d862c11f1

 

By using this API endpoint: https://developers.hubspot.com/docs/methods/forms/v2/create_form

 

All the fields was created with the API, and I have created the "zrh" field using the GUI.

 

Then I try to submit such a form. If I try to submit say the "mcuploadeddataset" field (created with the API), the POST /submissions/v3/integration/submit/7748313/6c32dbf4-4649-4a3b-b262-527d862c11f1  request returns a correct 200 but in the contact information, I only see:
"aevr aeefa submitted Test-7

No properties updated."

BUT if I submit the "zrh" field (created with the GUI), it works as excepted with the same POST request.
 
What is happening?
Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Highlighted
HubSpot Moderator

Hey @Sebbes,

 

Happy to help shed some lights here!

 

The reason why you're seeing no properties updated is because currently on portal 7748xxx, there is no property name - mcuploadeddataset.

 

If you'd like to pass custom property value through form submission, you'd need to first create the property.

Reply
0 Upvotes
2 Replies 2
Highlighted
HubSpot Moderator

Hey @Sebbes,

 

Happy to help shed some lights here!

 

The reason why you're seeing no properties updated is because currently on portal 7748xxx, there is no property name - mcuploadeddataset.

 

If you'd like to pass custom property value through form submission, you'd need to first create the property.

Reply
0 Upvotes
Highlighted
New Contributor

Thanks Wendy, I will try this solution. However, maybe this information should appear in the documentation because it is not obvious at all!

Reply
0 Upvotes