Error: Insufficient Scopes were provided. Please contact the integrator

SOLVE
mjuneja
Member

I am getting this Error, I have checked all Scopes are there. Still an issue:
Insufficient Scopes were provided. Please contact the integrator.

https://app.hubspot.com/oauth/authorize?client_id=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxx&scope=contacts content reports social automation timeline forms files hubdb transactional-email&redirect_uri=https://www.hubspot.com

0 Upvotes
1 Accepted solution

Accepted Solutions
Derek_Gervais
Solution
HubSpot Alumni

Hey @erikrahman2000 ,

This specific error (Insufficient Scopes were provided. Please contact the integrator.) occurs when the scopes requested in the authorization URL don’t match up with the scopes checked off in the app’s settings. @mjuneja resolved this issue by un-checking some scopes that he wasn’t requesting in his authorization URL. You can either:

  1. Go into your app’s settings and uncheck any scopes you’re not requesting
  2. Add scopes to your authorization URL, so that you’re requesting all scopes that are checked off in your app’s settings

View solution in original post

8 Replies 8
Derek_Gervais
HubSpot Alumni

Hi @mjuneja,

You should uncheck action forms, and also make sure that those spaces are URL encoded. Are you still seeing issues after trying that?

0 Upvotes
mjuneja
Member

Now I am getting different error.
You do not have the correct role to grant these permissions. Please contact your administrator.
I think after unchecking action forms, i need to remove some parameter in scope too… but I am not sure which scopes are related to action forms that should be removed.

0 Upvotes
mjuneja
Member

Worked with:

In Scopes I just passed contacts and automation

erikrahman2000
Member

Hi @mjuneja,

I am experiencing the same error and following what you did. Unfortunately, I am still having the error.
Here is my URL https://app.hubspot.com/oauth/authorize?client_id=xxx&scope=contacts%20automation%20workflows&redire...

Can you please let me know what is causing of error?

Thanks,
Erik

0 Upvotes
mjuneja
Member

Hi,

I changed my app. Now its working. But what is exactly issue… I still
don’t know. And in scopes while creating URL just pass contacts and
workflow.

Thanks,

Derek_Gervais
Solution
HubSpot Alumni

Hey @erikrahman2000 ,

This specific error (Insufficient Scopes were provided. Please contact the integrator.) occurs when the scopes requested in the authorization URL don’t match up with the scopes checked off in the app’s settings. @mjuneja resolved this issue by un-checking some scopes that he wasn’t requesting in his authorization URL. You can either:

  1. Go into your app’s settings and uncheck any scopes you’re not requesting
  2. Add scopes to your authorization URL, so that you’re requesting all scopes that are checked off in your app’s settings

View solution in original post

Vishalb
Member

Hi Derek,

From where do I access the "Scopes" section within the settings menu.

A search within settings didn't show any results for "scopes" search.

 

Thanks,
Vishal

 

0 Upvotes
erikrahman2000
Member

Hi @Derek_Gervais,

Many thanks for your reply, it works now!

Best Regards,
Erik