APIs & Integrations

Roxane05
Member

Domain not verified and token not working

Spoiler
    Spoiler
    Oauth for developing a Hubspot App: domain not verified, hubspot API unaccessible

Hello,

 

I am a bit confused with putting in place OAuth 2. My domain is still not verified after 48hrs and it seems that as long as it is not i cant access the API because the token generated seems not to be valid.

 

Can someone explain to me the process? I put the given hubspot txt field on my ovh dns www.webstreet.io and gave a callback url for the app, starting with the domain name, but it doesn't work. I use postman to try to perform a hubspot api call but i always have an error on the credentials.

 

Also, while waiting domain validation is it possible to access the API and start developing the app?

 

Here is the complete installation url for my app: https://app-eu1.hubspot.com/oauth/authorize?client_id=428d95a7-3cbd-456e-a581-35990fcae354&redirect_...

Screenshot_20220816-094314_Chrome.jpg

Any help will be highly appréciated.

 

0 Upvotes
1 Reply 1
Jaycee_Lewis
Community Manager
Community Manager

Domain not verified and token not working

Hi, @Roxane05 👋 In relation to your testing question, you'll need to either wait for the verification to update or use a private app meanwhile solely for testing purposes. 

 

For the delayed verification, it all occurs on the registrar side. Meaning, aside from disconnecting and starting over, there is nothing to do from the HubSpot side. If disconnecting and retrying doesn't get it to show as verified, I'd reach out to your registrar and verify the formatting for the records is in alignment with their requirements.

 

Best,

Jaycee

linkedin

Jaycee Lewis

Developer Community Manager

Community | HubSpot

0 Upvotes