Custom timeline event date not showing correctly

SOLVE
Highlighted
Occasional Contributor

Hi experts,

 

We create a custom timeline event. We added an attribute of time date.  We understood you need to add a date using the api as a unix time stamp in miliseconds (midnight GMT).

 

However, in the timeline event, this does not show as a date.  It just shows the time stamp (1557273600000 in this case).  

 

Screenshot 2019-05-09 at 12.05.27.png

 

Any suggestions?

 

 

Thx, Carl

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
HubSpot Moderator

Hi @cbouckae , in order to display the date/time in the formatted way and not in unix milliseconds, you'll need to make sure that within your event type, the detailTemplate field you have formatted the data to display the date in the format. 

 

For example: 

{{#formatDate installation_date}}{{/formatDate}}

This will display the installation_date property in the date format instead of in milliseconds. You can read more about this here https://developers.hubspot.com/docs/methods/timeline/timeline-overview#extra-data

Reply
0 Upvotes
1 Reply 1
HubSpot Moderator

Hi @cbouckae , in order to display the date/time in the formatted way and not in unix milliseconds, you'll need to make sure that within your event type, the detailTemplate field you have formatted the data to display the date in the format. 

 

For example: 

{{#formatDate installation_date}}{{/formatDate}}

This will display the installation_date property in the date format instead of in milliseconds. You can read more about this here https://developers.hubspot.com/docs/methods/timeline/timeline-overview#extra-data

Reply
0 Upvotes