APIs & Integrations

jandrews
Participant

Custom Property NOT delivered in Workflow Webhook

SOLVE

I am using a workflow webhook and it is successfully sending me meeting data to my desired endpoint after a meeting is booked, but there is one problem. The custom property is not being sent and I cannot figure out why.

 

I created the below property Unit ID and for some reason neither the key nor value is apart of the payload.

Screen Shot 2020-07-10 at 3.51.55 PM.png

 

0 Upvotes
1 Accepted solution
WendyGoh
Solution
HubSpot Employee
HubSpot Employee

Custom Property NOT delivered in Workflow Webhook

SOLVE

For posterity,

 

Issue

It looks like the `Unit ID` isn't a contact property (as I wasn't able to locate it on customer's property setting) but rather, a custom question. In this case, as the custom question isn't a contact property, the answer will not get saved on a contact record property. 

 

If we'd like to save the custom field on a contact property, we'd need to select 'Contact property' instead of 'Custom question':

contactProperty.png

View solution in original post

2 Replies 2
WendyGoh
HubSpot Employee
HubSpot Employee

Custom Property NOT delivered in Workflow Webhook

SOLVE

Hey @jandrews,

 

I tested it out on my own portal and I'm able to see the custom property on the returned response. 

 

In this case, could you share with me the following so that I can further troubleeshoot:

 

1. Portal ID in question

2. The workflow name/id in question

3. The meeting link in question 

 

If it's more comfortable for you, you can send it via DM to me.

WendyGoh
Solution
HubSpot Employee
HubSpot Employee

Custom Property NOT delivered in Workflow Webhook

SOLVE

For posterity,

 

Issue

It looks like the `Unit ID` isn't a contact property (as I wasn't able to locate it on customer's property setting) but rather, a custom question. In this case, as the custom question isn't a contact property, the answer will not get saved on a contact record property. 

 

If we'd like to save the custom field on a contact property, we'd need to select 'Contact property' instead of 'Custom question':

contactProperty.png