Can't update options for field with "optionsAreMutable": true

SOLVE
gabriel_gego
Member

Hi,

 

Whenever I'm trying to update a field that is defined by HubSpot but has mutable options I get this error: 

{
    "status": "error",
    "message": "The Property 'hs_lead_status' has a read-only definition, and can't be mutated.",
    "correlationId": "5e3fb902-2e59-458c-af32-4a76aabaa180",
    "requestId": "1bdf6284-6de0-4a77-bbad-bb658c381a0d"
}

However, this is editable in the web interface. So I should be able to update the options in the api as well. Right? 

 

Here's the complete request I'm doing:

 

PUT /properties/v1/companies/properties/named/hs_lead_status
Content-Type: application/json
cache-control: no-cache
Postman-Token: b22ecd3f-32e1-4358-8c17-86d7d28e9dc1
User-Agent: PostmanRuntime/7.6.0
Accept: */*
Host: api.hubapi.com
cookie: __cfduid=dfdb7971b28a2dfaa2db709cc20f9a6221558355631
accept-encoding: gzip, deflate
content-length: 1047
{ "options": [{ "label": "New", "displayOrder": 1, "hidden": false, "readOnly": null, "doubleData": null, "description": null, "value": "NEW" }, { "label": "Attempted to Contact", "displayOrder": 2, "hidden": false, "readOnly": null, "doubleData": null, "description": null, "value": "ATTEMPTED_TO_CONTACT" }, { "label": "Connected", "displayOrder": 3, "hidden": false, "readOnly": null, "doubleData": null, "description": null, "value": "CONNECTED" }, { "label": "Open Deal", "displayOrder": 4, "hidden": false, "readOnly": null, "doubleData": null, "description": null, "value": "OPEN_DEAL" }, { "label": "Unqualified", "displayOrder": 7, "hidden": false, "readOnly": null, "doubleData": null, "description": null, "value": "UNQUALIFIED" }] }

Is there a different way in which I have to call this api, in order to be able to update the options for these kinds of fields? Thanks

0 Upvotes
1 Accepted solution

Accepted Solutions
gabriel_gego
Solution
Member

If anyone else faces this problem. The solution is to use a PATCH request instead of PUT.

 

This can be closed now.

View solution in original post

2 Replies 2
gabriel_gego
Solution
Member

If anyone else faces this problem. The solution is to use a PATCH request instead of PUT.

 

This can be closed now.

View solution in original post

jennysowyrda
Community Manager

Thanks for sharing @gabriel_gego! 🙂 


We are excited to announce that the Community will be launching a weekly newsletter on November 2, 2020!
Sign up today!
0 Upvotes