CRM Search failing for double quotes

Highlighted
New Contributor

Hi Team,

I am using double quotes in CRM search but it is failing. I am getting error - 

problem: Filter value 'Optional[Wingless .001\" (.025 m]' has mismatched quotation marks". Could you please suggest how to pass double quotes in search.
 
DealSearchError.JPG
0 Upvotes
3 Replies 3
Highlighted
HubSpot Moderator

Hey @tanmay,

 

It looks like you posted a similar thread here and I've responded on that forum thread. Do let me know if you're still seeing the error after escaping the string on that forum thread. Thank you!

Highlighted
New Contributor

Thanks for you suggestion. After parsing Api if not falling but but it is not returning result. When i have used \\\" (in "propertyName": "deal_unique_id")  it din't return result set. Please find below -  

 

----------------------------------------Scenario-1----------------------------------------------------
Deal Search Input
{
"filterGroups": [
{
"filters": [
{
"propertyName": "oracle_account_number",
"operator": "EQ",
"value": "110192"
},
{
"propertyName": "enterprise_site_id",
"operator": "EQ",
"value": "114795"
},
{
"propertyName": "deal_unique_id",
"operator": "EQ",
"value": "114795-226--Sof-Tray Classic Sheets (0.035\\\")"
}
]
}
]
}
Deal Search Output
{
"total": 0,
"results": []
}
--------------------------------------Scenario-2-------------------------------------------------------

Deal Search Input
{
"filterGroups": [
{
"filters": [
{
"propertyName": "oracle_account_number",
"operator": "EQ",
"value": "110192"
},
{
"propertyName": "enterprise_site_id",
"operator": "EQ",
"value": "114795"
}
]
}
]
}
Deal Search Output
{
"total": 1,
"results": [
{
"id": "2741226816",
"properties": {
"amount": null,
"closedate": null,
"createdate": "2020-07-31T21:00:04.034Z",
"dealname": "Sku:114795-226--Sof-Tray Classic Sheets (0.035\")",
"dealstage": null,
"hs_lastmodifieddate": "2020-07-31T21:00:11.900Z",
"hs_object_id": "2741226816",
"pipeline": null
},
"createdAt": "2020-07-31T21:00:04.034Z",
"updatedAt": "2020-07-31T21:00:11.900Z",
"archived": false
}
]
}

0 Upvotes
Highlighted
HubSpot Moderator

Hey @tanmay,

 

I believe this is likely because property `deal_unique_id` doesn't exist. As discussed on this forum thread. Let's keep our conversation on this forum thread moving forward :cathappy: 

0 Upvotes