Blogs API issue

Aleksei
Member
Good day!

Yesterday I started to see errors like
{“status”:“error”,“message”:“User does not have permission to get the resource with id null.“,”errorType”:“SCOPE_RESTRICTED”,“errorTokens”:{“modelId”:[“null”],“action”:[“get”]},“correlationId”:“8532d03e-4adb-4866-857c-7997eccca949"}
 
while calling GET /content/api/v2/blogs

Other endpoints with same scope continued to work well for the same accounts.

Seeing this for more than a hundred portals.

Any ideas what’s going on?
0 Upvotes
2 Replies 2
dennisedson
Community Manager

Hello @Aleksei,

This looks extremely similar to this community thread.

Looks like you might work together actually.

 

@annapurna could you provide any insight here?

 

Thanks!

 

Thanks,

Dennis


We are excited to announce that the Community will be launching a weekly newsletter on November 2, 2020!
Sign up today!
0 Upvotes
annapurna
Participant

Hi @dennisedson 

This is the answer I got in DM when we had one or two cases back in July and the answer arrived a bit late and we stopped getting those errors

 

Answer from @WendyGoh 

 

-----

 

Hey there!

 

Apologise on the delayed in response.

 

Researching into the error message, I wasn't able to locate any resources that indicates what could have caused this error.

 

Having said that, based on the error, it looks like it is regarding the user permissions. As such, I found out that the user who authenticate the `{app_name_removed}` app was user Sean and Sean is no longer a user in portal {portal_id_removed}. Hence, this could likely be why your team is getting the error. 

 

Could we get portal ID {portal_id_removed} to reinstall the `{app_name_removed}` app > Call the GET /content/api/v2/blogs?limit=250&offset=0 > Check if your team is still getting the SCOPE_RESTRICTED -- modelId error?