API - create contact - view inside contacts list - delay ?

SOLVE
New Contributor

Hi,

 

I am creating a new contact using Hubspot API [and a valid API key]:

https://api.hubapi.com/contacts/v1/contact?hapikey=my_api_key

Method is cURL from PHP, all things are good, contact is created, status returned 200, etc.

 

My problem: when I check this contact inside contacts list, I notice is not there.

However I am able to see it using an url like this:

https://app.hubspot.com/contacts/6941921/contact/27551

 

Next step: I call API again and create a new contact.

 

!!! After second contact is created, the first one appears inside contacts list !!!

 

This is like list is waiting for a new contact, to push the previous one into list.

 

Any idea why? Any parameters that should be added to force real time populating list?

 

Thanks a lot,

Adrian

 

PS: I am new here, doing stuff for a client Smiley Happy

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Highlighted
HubSpot Moderator

Hi @adrian-neacsu 

 

I can confirm that it is expected that there should be a delay between the contact being created and appearing in any contact lists. The delay is minimal and should not impact any processes heavily but should be account for when testing. 

 

If you're looking to automate this process, you will need to include a delay to allow for the system to create and update the record, thus populating it on the contact list for you.

 

I hope this helps!

Matthew Willson

HubSpot Developer Support
2 Replies 2
Highlighted
HubSpot Moderator

Hi @adrian-neacsu 

 

I can confirm that it is expected that there should be a delay between the contact being created and appearing in any contact lists. The delay is minimal and should not impact any processes heavily but should be account for when testing. 

 

If you're looking to automate this process, you will need to include a delay to allow for the system to create and update the record, thus populating it on the contact list for you.

 

I hope this helps!

Matthew Willson

HubSpot Developer Support
Highlighted
New Contributor

Hi,

 

Yes there is a delay, but it's short.

My problem was the Chrome browser that didn't refresh data properly. After I cleared the cache, all records were there.

 

All good.

 

Thank you,

Adrian

 

 

 

Reply
0 Upvotes