APIs & Integrations

udayapitchika
Member

500 Internal Server Error when trying to access settings endpoint

Hey @Llewellyn_Smith,

I'm getting 500 Internal Server Error when trying to access /settings endpoint (both GET & PUT requests)

These requests were working last week, not sure what changed.
https://api.hubapi.com/extensions/ecomm/v1/settings?appId=57790&hapikey=0ff7eeee-29b9-4492-8051-c3b9315cdece

Here are the response headers incase if you can make out any useful information about the error-

Access-Control-Allow-Credentials →false
CF-RAY →3fb1cf935b0f9598-IAD
Connection →keep-alive
Content-Length →0
Date →Tue, 13 Mar 2018 22:06:59 GMT
Expect-CT →max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
Server →cloudflare
X-Trace →2B2FC9F345681577D2AB3A94D17DC54C5E477D1CE4BEF376120EBEB4F201

Could you please check and let me know how to fix this? You can clear out all the mappings that we currently have if required.

0 Upvotes
4 Replies 4
udayapitchika
Member

500 Internal Server Error when trying to access settings endpoint

Hi @Llewellyn_Smith

Thank you for your help.

We are able to access /settings end point now. Getting 500 Internal Server Error from/import-settings endpoint, however. Could you please check and fix this error ?

Also, if I understand correctly, /installs endpoint will be useful when developing on an individual portal and NOT for application development. A POST request to /extensions/ecomm/v1/installs endpoint, will enable all the eCommerce specific endpoints & dashboards on a specific portal. What should be the body of this POST request? Could you please provide an example?

lsmith
HubSpot Product Team
HubSpot Product Team

500 Internal Server Error when trying to access settings endpoint

Hi @udayapitchika,

Again, I'm sorry about this issue. Apparently the problem was more widespread than we realized. The /import-settings endpoint, along with all others, is fixed now.

About the /installs endpoint, that is correct. For eCommerce applications that users install, we will automatically take care of the eCommerce installation process on their portal so no action is required by the application.
To answer your question, no body is required for the POST request to /installs. We don't need any data, it is simply a trigger to start the install process.

I hope that helps!

himanshurauthan
Recognized Expert | Diamond Partner
Recognized Expert | Diamond Partner

500 Internal Server Error when trying to access settings endpoint

thanks @Llewellyn_Smith,

About the /installs endpoint, it is working and it installs the Ecommerce related fields, but the response is 204, so is it ok, so for the duplicate question, but i found that this is more relevant.

Thanks.

Digital Marketing & Inbound Expert In Growth Hacking Technology
0 Upvotes
lsmith
HubSpot Product Team
HubSpot Product Team

500 Internal Server Error when trying to access settings endpoint

Hi @udayapitchika,

I'm sorry about this issue. Nothing is wrong with your settings. We made a change to the way our response data was serialized and this caused the 500s.

This is fixed now, please let me know if you have any further problems.